Region Canada-Ontario wireguard problems on windows
Incident Report for KeepSolid
Resolved
This incident has been resolved.
Posted Nov 04, 2022 - 09:55 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 03, 2022 - 13:48 UTC
This incident affected: VPN (Canada-Ontario: Ontario, Toronto).